
 RMRBank (for Windows Mobile) Personal Accounts Suite

RMRBankRMRBank
Personal Accounts SuitePersonal Accounts Suite
(for Windows Mobile)

User GuideUser Guide

© RMR Software 2004
All rights reserved

Contents
Contents                                                                                                                            ........................................................................................................................  1  
RMRBank                                                                                                                          ......................................................................................................................  2  
Currencies                                                                                                                         .....................................................................................................................  3  

Currency Conversion                                                                                                     .................................................................................................  3  
Accounts Screen                                                                                                               ...........................................................................................................  4  

Create Accounts Groups                                                                                               ...........................................................................................  4  
Add Accounts                                                                                                                 .............................................................................................................  4  
Look Ahead / Pay Bills                                                                                                   ...............................................................................................  5  
Backup and Restore                                                                                                      ..................................................................................................  5  
Import and Export                                                                                                          ......................................................................................................  6  

Preferences                                                                                                                       ...................................................................................................................  7  
Transactions Screen                                                                                                          ......................................................................................................  8  

Add Transactions                                                                                                           .......................................................................................................  9  
Default Transactions                                                                                                    ................................................................................................  10  
Auto-Counters                                                                                                              ..........................................................................................................  10  
Tax Facility                                                                                                                   ...............................................................................................................  10  
Filter Transactions                                                                                                       ...................................................................................................  11  
Archive or Remove Transactions                                                                                ............................................................................  11  

Categories Screen                                                                                                           .......................................................................................................  12  
Add and Update Categories                                                                                        ....................................................................................  12  

Orders Screen                                                                                                                 .............................................................................................................  13  
Add Orders                                                                                                                   ...............................................................................................................  13  
Add Interest Payments                                                                                                ............................................................................................  13  

Archive Screen                                                                                                                ............................................................................................................  15  
Additional functions                                                                                                         .....................................................................................................  15  

www.rmrsoft.com page 1



 RMRBank (for Windows Mobile) Personal Accounts Suite

RMRBank
RMRBank Personal Accounts Suite is a comprehensive package with a fully integrated range 
of functions for managing your personal and home finances. The program consists of 5 screens 
accessible from the buttons at the top of the screen or from the View menu:

Accounts:
• This lists all your bank, savings, credit or debit cards and other accounts with their balances, 

and shows your total worth. Accounts can be held in one or more Groups each of which can 
be operated in different currencies.

Transactions:
• Where you enter and record all your incoming and outgoing transactions for each account.

Categories:
• To keep track of your outgoings by allocating transactions to Budget Categories, similar to 

those used in Quicken.

Orders:
• To setup regular Standing Orders (aka Direct Debits or Future Transactions) and estimated 

interest payments made to/from accounts.

Archive:
• Allows you to keep a permanent record of transactions after they have been reconciled and 

removed from the live accounts.

In addition, if you also have our RMRFuel program, transactions can be made to transfer 
purchases to this program for your fuel costs and vehicle expenses. Similarly, travel expenses 
can be automatically added to RMRExpenses if it is installed.
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Currencies
The currency entered on first startup will be used as the primary currency to run the first Group 
in. Other currencies can be added if you want a Group of Accounts stored in a different 
currency, or for use when travelling to foreign countries.

These currencies will then be available in the add screens for temporary use when adding 
entries e.g. while on holiday. The costs will be converted to your primary currency at the rates 
you have set. If you set a currency Secondary (2ry) Currency, the currency selection box will 
always default to that currency if the Foreign option is selected.

The symbol of the currency applicable to the Group and Account is shown above the scrollbar. 
Tap on this to enter or update currencies.

To add a currency
• Use Edit > Currencies and the New button

• Define a name, symbol and the exchange rate to your 
primary currency. Tick the 2ry checkbox if you want this 
to be the default foreign currency.

To update an exchange rate
• Use Edit > Currencies

• Select the currency, and change the rate to the current exchange rate.

To delete a currency
• Use Edit > Currencies

• Select the currency, and use the Delete button.

Note that if you have more than one RMR Software program, the currency file is shared 
between them and may be updated from any of the programs.

Currency Conversion
A handy currency Conversion feature is available from the Tools menu in all screens. This 
allows you to convert an amount from / to any of the currencies that you have added to the 
currency file.
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Accounts Screen
This is the 'top-level' screen which lists the accounts in the selected Group, along with their 
current balance, currency of operation, the net worth for the Group and your overall total for all 
groups.

You can display an extra column in the Accounts 
screen to show various account settings for the 
Account Type, applicable Interest Rate, Balance 
Limit or Reference. Turn this on initially with Tools > 
Preferences > Display, then tap the column title to 
cycle through them. (If you select "All", it will look 
through the settings in the order : Ref, Limit, Interest 
& Type and display the first non-blank entry. To 
force a blank just put 2 spaces in the Reference 
field).

Tap the currency symbol above the scrollbar, or use 
Edit > Currencies menu to show the Currencies 
dialog to add new currencies or change their rates.

Groups can be individually Password protected if 
required with the option in Edit menu.

Switch Groups using the dropdown selector at top 
right of the screen.

A Notepad facility in View menu (from all screens) 
allows you to record any information about the 
Group of accounts.

Use Account details from the View menu to record account numbers, bank codes, card numbers 
or other details for each account.

Create Accounts Groups
You can have just one Group for all your accounts, or create multiple Groups for normal 
accounts, savings accounts, business accounts, foreign accounts etc.

All accounts in a Group must be run under the same currency, so if you operate in more than 
one currency you will need multiple Groups. Each Group of accounts can access a common set 
of Categories or use different Category files.

• tap Edit > Groups > Add and specify a name for the 
group, select the currency to operate in, and set the 
related group of Categories. (These must be created 
beforehand).

• tap Edit > Groups > Update to change the name or 
currency of operation, or associated Categories for a 
group.

• tap Edit > Groups > Delete to completely remove a group of accounts.

Add Accounts
In the Accounts screen tap New to add accounts, and enter their details:

• a Name for the account

• any reference details

• the opening Initial balance, and whether it is in credit or debit
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• whether the balance of the account should be included in the Group total (included accounts 
are shown with '>>' in the first column.

Then tap the Advanced button to define:

• the Account Type (as Bank, Credit Card, Cash, Asset, Liability, or Shares)

• any Balance limit, either a minimum credit for a checking (current) account, or a maximum 
debit for a credit card type account

• the Credit and Debit interest rates applicable, for use by the Standing Orders interest 
transactions

• the Archive file to be associated with the account (these must be created beforehand).

• If you also use our separate RMRInvest program to monitor your investments, an 
Investment link option will be present here. This feature allows you to include the value of 
your investment portfolio in your Account Group total, by creating a pseudo-account of Type 
= Shares and linking this to your RMRInvest file.

Use the Edit menu options to Update or Delete accounts, or to Move them in the list.

Look Ahead / Pay Bills
Use the Look Ahead mode to predict the state of your finances at some time in the future, after 
Standing Charges have been actioned, and deferred entries included.

Tap Data > Look Ahead in the Accounts screen and specify a future date. Note that it may take 
some time to action all the future standing charges etc.

To show you are in Look Ahead this is indicated in a bar at the bottom of the screen. While in 
Look Ahead mode you can view the Transaction screen for any account, but you will not be 
allowed to access Categories, Direct Debits or Archive screens.

Tap Data > Cancel Look Ahead, or tap the Look Ahead indicator bar to exit Look Ahead mode.

Use the Data > Pay Bills option to action all the Standing Orders up to a chosen date. You can 
either allocate today's date or the date of the Standing Order. Note that this is a permanent 
action unlike under Look Ahead.

Backup and Restore
The program has Backup and Restore options in the Data menu of most screens:

• Use Backup data to regularly make a second copy of your data files in the ‘My Documents’ 
folder in case of accidental deletion or loss. In that way the data can also be saved to a PC 
each time you hot-sync. (Although you can elect to store the backup on an external storage 
media if you wish, through Tools > Preferences > Backup).

• Use Restore to subsequently reload the backed up files if necessary. The program will 
restore the files from the media selected in Tools > Preferences > Backup.

• You can select an Auto-Backup feature through Tools > Preferences, which saves you 
having to remember.
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Import and Export
In the Data menu of Accounts, Transactions and Archive screens there are options to Import 
and Export your transactions data using the Quicken Interchange Format (QIF), the standard 
used by most financial programs.

These provide one-off methods of transferring data or populating RMRBank with existing 
accounts data, and are not intended as a means of synchronizing two financial programs.

Import of QIF Data
To import Transaction entries from another program into an Account or Archive file:

• First use the Export function in Quicken or other financial program, ensuring that the only 
option selected is for Transactions data.

• Check the date format (MM/DD/YY or DD/MM/YY) of the created QIF file - a QIF file is 
simply an ASCII text file in an agreed format, so can be viewed in any text editor.

• Link your Pocket PC to PC and synch or copy the QIF file to My Documents.

• Select (or first create) an account or archive in RMRBank.

• Note: if the original transactions (in Quicken etc) were assigned to Budget categories, for 
these to be recognized during the import they must first be created in RMRBank Categories. 
The program will not create them if a match is not found!

• Use the Data > Import menu option. The file selector dialog will show all QIF files on the 
machine. Select the appropriate file.

• in the Import dialog, verify that the QIF file and To Account/Archive are correct, and select 
the date format to match the file (you will be warned on import if it is incorrect).

• Tap OK to import the entries. The details should then be imported. (Note this may take 
some time).

Export of data
Transactions data from an Account or Archive in RMRBank can be exported in QIF format for 
use in other financial programs. In addition, export of the data can also be performed as CSV 
(comma separated variables) and ASCII (tab separated) formats for use in spreadsheets or 
other programs.

• View the appropriate account or archive, and use the Data > Export menu option and select 
the format (QIF, CSV, or ASCII).

• The file will be saved in the My Documents folder with the same name as the account or 
archive.

• Copy or Synch the file to your PC, where Quicken or other financial program should happily 
import it.
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Preferences
Tools > Preferences gives access to many options for configuring the display and operation of 
the program:

Font
Set the screen display for the records:

• Font type and Size

• Color

• Font style - bold, Italic, Underline, Strikeout.

Decimal places
• Set the Number of Decimal places for all currency values. Applies specifically to the Group.

Colors
Set your color choice for:

• Screen background

• Column headers

• Screen buttons

• Selected screen button

• Dialog background.

Display
• Define which information the middle column should show - Account Type, Interest Rate, 

Balance Limit, Reference or All. (If you select "All", it will look through the settings in the 
order : Ref, Limit, Interest & Type and display the first non-blank entry. To force a blank just 
put 2 spaces in the Reference field)

• Define whether negative amounts are shown in red, as a minus, or in brackets.

• Configure the width of the columns on the display.

Settings
• Warning total: under normal use the program will keep track of the number of 'warning' 

entries. However, there are occasions such as the complete deletion of a Group, when the 
counter can get misaligned. Use this option to reset the counter (If you have warning 
transactions a '!' will appear in the small window at the bottom right of the screen).

• An option to enable/disable the pop-up keyboard in Landscape mode.

Backup
• Specify the location for backup files and whether you wish the program to carry out a 

backup automatically at set periods.

There are additional Preferences in each screen related to that specific screen.
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Transactions Screen
This screen shows all the current transactions made in the selected Account. The initial opening 
balance is shown above the values column (or tap to toggle the value to show the number of 
entries). The current balance is shown at the bottom (or tap to toggle the values for Reconciled 
total, or Running balance).

The right hand column by default shows the transaction credit or debit values. Tap on the 
column title to show alternative values - the Running total, Tax amount, or Net value less the 
tax.

The middle column can show various settings for the transactions, including Category, 
Reference, Counter, Foreign cost, Tax amount, entry index number, the other account name if it 
was a transferred transaction, or the Value itself (for use if the last column is set to show 
Running total). Set the middle column with Tools > Preferences > Display, or tap the column title 
to select an alternative unit.

The total transaction entries in the account file are buffered for speed of display on screen. The 
default buffer size is set to 12 entries (the number of visible lines on screen), but is configurable 
with Tools > Preferences > Display.

To move around transactions:
• tap the S button to jump to the Start of the file (earliest transactions)

• tap the Prev button to display the previous display buffer

• tap the Next button to display the next display buffer

• tap the E button to jump to the End of the file (most recent transactions)

• use Tools > Jump to date to show the screen with a particular dated transaction.

Switch Accounts (or go to another Group of accounts) using the dropdown selector at top right 
of the screen.

There are various methods for entering and managing transactions:

• tap New to add basic transactions

• tap the Default button, or use Edit > Add default entry to add pre-setup Default transactions 
for regular transactions with the same settings
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• tap Edit > Add last entry to repeat enter the last transaction

• tap Edit > Move entry to move or copy (delete after move) a transaction to another group or 
account

• tap Edit > Update to change an existing entry

• tap Edit > Delete to remove an unwanted transaction.

Attributes
The R, E, D, and ! buttons (paralleled with Edit > Attribute menu) allow you to flag transactions 
in various ways:

• R - Reconcile (marked with ®) after you have checked the entry against a bank statement.

• E - Estimated (±) when you want a record of a transaction, but may not know the exact 
amount yet.

• D - Deferred so that it is still displayed, but may or may not be included in any balance 
calculations, depending on the preference setting.

• ! - Warning so that it is not included in the Balance, but is left there as a reminder (eg to pay 
the rent).

Use Tools > Foreign currency, or tap on the button under the scrollbar, to turn on/off the ability 
to enter transactions in another currency temporarily if you are on holiday or travelling. To show 
this option is selected an 'F' will appear in the small window at the bottom right of the screen.

Add Transactions
In the Transaction screen tap New to add transactions to the account, and enter their details:

• select the Date

• add a Description

• enter the Amount as a Credit or Debit

• select a Budget Category from those you have pre-
defined

• add any other notes in the Reference field

Then tap the Advanced button and as required:

• select an Attribute to flag the transaction (Reconciled, 
Estimated, Deferred or Warning)

• select a Counter for automatic numbering (e.g. for a 
check/cheque)

• apply a Tax Rate from those you have pre-defined, or 
None, or a one-off rate

• select another Group and Account to transfer to. 
Transactions can transfer details to another account 
(even in another Group), e.g. to pay a credit card bill 
with a check/cheque. A reciprocal entry will be made 
in the 'to' account.

• if you also have RMRFuel or RMRExpenses installed, 
you have the option to select a Vehicle and transfer 
the amount to that program as a Fuel cost or vehicle 
Expense.  Tap the Links button to access the screen.
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• Add default entry and Add last entry work in similar ways, except that the entry fields will be 
pre-completed with the details. Modify if required, then tap OK to submit the transaction.

• use Edit > Update entry if you need to correct the details of any entries.

• use Edit > Delete entry if you need to remove an entry.

Note that there is a Resort Entries option in the Tools menu which can be used to fix any date 
ordering problems which may result from updating, deleting or moving transactions.

When travelling in another country, tap Tools > Foreign currency. The Add transaction dialog 
will then have an extra field for currency selection. The amount will automatically be converted 
to the currency defined for the Group, and the original amount recorded in the For field viewed 
by toggling the middle column.  To show this option is selected an 'F' will appear in the small 
window at the bottom right of the screen. 

If you wish to put in a transaction for a future date, the Preferences > Settings determines how 
these Deferred transactions are handled. With Auto-defer transactions set, any future 
transaction will be automatically flagged as deferred, not included in the balance, but 
automatically cleared once the date is reached.  A further option allows you to Include Deferred 
Values into the running balance if you wish.

Default Transactions
If you have a transaction you enter regularly that has the same settings, such as an Electricity 
Bill that always pays the same company and updates a Category, and the only difference is the 
amount, then it is best setup as a Default Transaction:

• tap Tools > Setup defaults > Add default in either the Accounts or Transactions screens. 
Give it a recognisable name, complete the transaction details that will never change, and 
save it.

• tap Tools > Setup defaults > Update default or Delete default to change or remove any 
default transactions.

To use Default transactions, in the Transactions screen tap the Default button, or use Edit > 
Add default entry, select the default by Name, change any details as required, and enter.

Note that the Default Transactions are specific to the Group in which they were created.

Auto-Counters
Often you need to keep a counter associated with a certain action, such as a check (cheque) 
book or paying-in book. The program allows for this using Auto counters.

To set up a Counter tap Tools > Auto counters. Enter a name for a spare counter, set a value as 
the next number you wish to use, and tap Update to save it, and Finish when all counters have 
been added.

The Counters can be used for normal transactions, from within Default transactions, or even in 
Standing Orders. Repeated use of a counter will increment the number by one. Note that 
counters are common across all Groups.

View the counter assigned to an entry by toggling the middle column of Transactions screen to 
show Count.

Tax Facility
A transaction can be allocated a tax value by selecting it in the Advanced dialog. The choices 
are <None>, any of 4 pre-defined rates, <Zero> or some other value. Note that <None> and 
<Zero> are not the same: <Zero> means an item is liable for tax, but at a zero rate.

You can then view the tax rate assigned to each entry by toggling the middle column of the 
Transaction or Archive screen to show Tax. View the actual tax amount payable on each 
transaction (or the Net Value), by toggling the Value column header.
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Filter Transactions
The entries in both the Transactions and Archive screens 
can be filtered to show only those that meet your selected 
criteria.

Tap Tools > Filter Display and enter any combination of 
criteria:

• Tick the Filtered checkbox to apply the filter. Untick to 
remove the filter.

• Select a combination of filters:
- by Category
- on a Text string
- by Date range
- by the amount (equal to, less than or more than a credit or debit value).
- by Account (Archive screen only) 

A coloured 'Filtered' bar at the bottom of the screen indicates that a filter is applied and allows 
quick access to the filter set screen for applying another filter, or turning it off.

Archive or Remove Transactions
When you receive a bank or credit card statement, the recommended procedure is to check the 
entries in the account and reconcile each by tapping the R button to mark with ® symbol. The 
Balance figure at the bottom of the screen will change to show the running reconciled total, 
which should match the running balance on your statement.

An option in Tools > Preferences > Settings can be turned on for Auto-step on reconcile. The 
highlight will then automatically move down to the next unreconciled entry after one is 
reconciled.

When entries have been checked use Edit > Archive entries to archive the reconciled 
transactions from the live account to make room for new transactions, and to store them in an 
Archive file (these must be created beforehand).

Note that, if required, the Archive entries dialog gives the additional flexibility of:

• Archiving or Removing (deleting) the entries

• Acting on only the Reconciled entries, or All entries

• Specifying the Start and End dates.
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Categories Screen
This screen allows you to keep track of how much you are spending (or receiving) for various 
budget expenses (Oil, Gas, Rent, Holiday, Food, Car, Salary etc.) by allocating transactions to 
categories. Totals of the Spend and Income amounts are shown at the bottom of the screen.

The total entries in the Category file are buffered for 
speed of display on screen. The default buffer size 
is set to 13 entries (the number of visible lines on 
screen), but is configurable with Tools > 
Preferences > Display.

Tap the currency symbol above the scrollbar to 
recalculate the budget amounts into each defined 
currency in turn, so the same set of Categories can 
be used from any Accounts Group.

Alternatively, you can create multiple Category 
Groups using the Edit menu > Category Groups 
options. Then associate the group with a specific set 
of accounts from Add or Update Group in the 
Accounts screen.

Switch Category Groups using the dropdown 
selector at top right of the screen.

The category entries in the file are buffered for 
speed of screen display. The default buffer size is 
configurable with Tools > Preferences > Display, 
and again use the S, Prev, Next and E buttons to 
move around the entries. Use Edit > Sort Categories 
to display the entries in either Ascending or Descending alphabetical order.

When entering a transaction into an account, select one of the categories in the Category field. 
The value of the credit or debit will be automatically added to the Spend figure for the category, 
and the % complete calculated. If the transaction in an Account is later deleted or updated, the 
Category value will be adjusted accordingly.

At the end of an accounting period, use Edit > Reset categories. Options are to:

• reset just the Selected category or All categories

• reset the Estimate value to the Current spend (i.e. last year's actual spend becomes next 
year's budget estimate), or to Zero it, or to leave it at the current amount.

• reset the Spend/Income amount to zero, or leave it alone.

Add and Update Categories
Tap New to add categories in the Category screen:

• specify a Name for the category
• enter an Estimate of the total amount likely to be spent/received, and whether it is a Debit or 

Credit (spend or income)

The usual options are available to Update, Delete, and Move the categories. When updating a 
category you have the ability to:

• change the Name
• change the Estimate to a new credit or debit amount
• change the Spend / Income value by either a credit or debit amount, or to give it a new 

absolute value.
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Orders Screen
This screen shows details of your Standing Orders 
and Interest payments made to or from accounts. 
Each Accounts Group has its own related Orders 
screen. Note that this screen can be titled Future 
Transactions, Scheduled Transactions or Direct 
Debits by using the Terminology setting in Tools > 
Preferences.

Orders can be for a regular amount, have a different 
first payment, or be a variable value to be specified 
each time. Action dates can be for any multiple of 
daily, weekly, monthly or annual periods.

Note that when an order has completed the requisite 
number of times, the date will change to 'Completed' 
in case you wish to reset it.

Use Tools > Action now to 'force' an order to 
transact ahead of its due date, when it can be set to 
either the order date or the date of actioning.

Add Orders
In the Orders screen tap New to add an order:

• set the initial Date you first wish it to be actioned

• specify the 'from ' or 'to' Account (or both for a transfer between accounts)

• add a Description

• enter the normal Amount to pay, or tick the Variable checkbox (in which case you will be 
asked for the amount each time the order actions)

• select the Period as Daily, Weekly, Monthly, or Annually

• select the Interval for how often the Period should occur.
Therefore, for a quarterly order submit a period of 'month' and an interval of 3.

Then tap the Advanced button to define:

• the text to appear in the Reference field

• an Initial Payment value (as the first payment is often different)

• select an Attribute to apply (Reconciled, Estimated, Deferred, or Warning)

• an Auto Counter to use

• the Number of times the order is to be carried out

• a Category

Add Interest Payments
In the Orders screen use Edit > Add interest payment to create a specialized type of order to 
make estimated interest payments to accounts:

• select the first Date for actioning

• select the Account

• add a Description

• the Debit/Credit Interest rates shown will be those originally defined during Account set up

• select the Period as Daily, Weekly, Monthly, or Annually
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• select the Interval for how often the Period should occur.

When the Interest order actions, the actual amount credited or debited to an account will simply 
be based on the interest rates set for the account and its balance at the time.
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Archive Screen
This screen allows you to look at transactions previously archived from Accounts. It is similar to 
the Transactions screen, the only difference being that you cannot edit the entries.

The bottom window defaults to displaying the number of entries, but if you tap the "Entries" 
button it will show the total balance.

Use Edit > Create archive in the Accounts screen, or tap New in the Archive screen to create 
new archive files. You can have one shared archive for all accounts, or an unlimited number 
one for each of your accounts. Edit menu options also allow them to be Renamed or Deleted.

The total transaction entries in the archive file are buffered for speed of screen display. The 
default buffer size is configurable with Tools > Preferences > Display, and again use the S, 
Prev, Next and E buttons to move around the entries. The entry ids visible are shown at the 
bottom of the screen.

Also use Tools > Preferences > Display to define which information the middle column should 
show.

Other functions available in the Tools menu are:

Find
Find and Find next functions for text entries.

Filter display
Allows you to view only the entries that match a particular Category or text string.

Reset start date
Use this to remove earlier unwanted entries if the file gets too big.

Jump to date
Shows the screen with a particular dated transaction.

Jump to entry
Shows the screen with a particular transaction index number from the whole file.

Additional functions
Register Program
Use Tools > Register program to enter your personal registration code to allow full use of the 
program without data restrictions. This function is also available from the opening 'nag' screen.

About
Use Tools > About to obtain contact details for RMR Software and information about the 
program.
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