
 RMRTask (for Windows Mobile) Extended ToDo Manager

RMRTaskRMRTask
Extended ToDo ManagerExtended ToDo Manager
(for Windows Mobile)

User GuideUser Guide

© RMR Software 2003

All rights reserved

Contents
Contents                                                                                                                                                     .................................................................................................................................................  1  

RMRTask                                                                                                                                                    ................................................................................................................................................  2  

Tasks Screen                                                                                                                                         .....................................................................................................................................  2  

Task Group Files                                                                                                                                    ................................................................................................................................  3  

Project and Type Categories                                                                                                                  ..............................................................................................................  3  

Add Tasks                                                                                                                                              ..........................................................................................................................................  3  

Repeating Tasks                                                                                                                                    ................................................................................................................................  4  

Default Tasks                                                                                                                                         .....................................................................................................................................  4  

Sorting                                                                                                                                                    ................................................................................................................................................  4  

Managing Tasks                                                                                                                                     .................................................................................................................................  5  

Filtering                                                                                                                                                  ..............................................................................................................................................  5  

Completing Tasks                                                                                                                                   ...............................................................................................................................  6  

Preferences                                                                                                                                            ........................................................................................................................................  7  

Archive Screen                                                                                                                                           .......................................................................................................................................  9  

Other Archive Functions                                                                                                                         .....................................................................................................................  9  

Additional functions                                                                                                                                   ...............................................................................................................................  11  

Backup and Restore                                                                                                                             .........................................................................................................................  11  

Export Entries                                                                                                                                       ...................................................................................................................................  11  

www.rmrsoft.com page 1



 RMRTask (for Windows Mobile) Extended ToDo Manager

RMRTask
RMRTask 'Extended ToDo Manager' for Windows Mobile allows you to record and monitor your 
various tasks (To-Do's) in a structured way. It comprises 2 screens:

Tasks screen
• For entry, viewing and scheduling of active tasks

Archive screen
• To view the completed task history

Create separate Task Group files to represent separate work, home, hobby or personal areas, then 
define Project and Type categories to allow you to categorise various assignments and their actions. 
Then enter your Tasks with a description, assign them to the categories, and set a due date, priority, 
optional repeat, and extended description.

The tasks can be sorted and filtered on various attributes to assist with scheduling and managing your 
time. Completed tasks can then be struckout and either deleted or, more typically, archived to a 
separate file as a permanent record.

Tasks Screen
The Tasks screen is where you record and manage your todo entries. The details are shown in 
several columns - Due Date, Priority, Description, two optional Categories (Project and Type), and 
Repeat flag.

To view and manage your tasks, sort them into your preferred order by tapping on the column title, or 
use the selector at the bottom of the screen. The blank button above the scrollbar will turn the sort 
method off, and allow manual sorting. Use the Tools > Filter option to view only the tasks that match a 
specified criteria.

If you have more than one Task Group file switch between them using the file selector at top right.

At the bottom of the screen 4 buttons allow quick access to: 

S - to strikeout completed tasks

P - to set a task "in progress"

T - to set the date of a task to 'today'

X - to view the Extended Text entry for the task.
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Use View > Notepad to record any miscellaneous information about the Task Group itself.

Task Group Files
Task Groups are the top-level categorization for your tasks. They allow you to store lists of completely 
unrelated and independent tasks in separate files. Any number of Task Group files can be created and 
used how you wish. Typically you would have Groups for Work and Personal Todos, but set them up 
as you require.

Tap Edit > Groups > Add to create a new Group file:

• give it a Name

• set the Archive Link to the archive file (this must 
have been created previously) that is to be 
associated with this task group.

Tap Edit > Groups > Update to change any details for a Group, or tap Edit > Groups > Delete to 
remove Groups if no longer needed.

Project and Type Categories
Two separate categories - Projects and Types - are available for assigning tasks against. Use them as 
you wish but typically Projects would be for major sub-divisions or assignments, and Type for the 
actions and activities involved. 

• tap Edit > Project (or Type) > Add to create a new category,

• tap Edit > Project (or Type) > Update to rename a category. Note that changing a category 
name will not dynamically change any tasks assigned to it - you will manually need to 
update these task entries to the new category,

• tap Edit > Project (or Type) > Delete to remove categories.

Categories are 'global', so you only need to create them once and they will be available in all Task 
Groups.

Change the 'Project' or 'Type' category names themselves (as used in the menus and screen 
columns) using Preferences > Category Names if you feel another title is more appropriate. Titles are 
Group specific.

If you don't wish to use one or other or both of the categories, they can be individually disabled in 
Preferences > Settings.

Add Tasks
Tap New to add add a task to a Task Group, and enter the 
details:

• set if it should be Dated or not, and

• select a Due date

• add a Description

• assign Project and Type categories

• set a Priority value, or None for an unprioritised 
task

Then as necessary:

• tick the Repeat box to turn on the repeating action, and set a Period and Interval.
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• use the Text button to write an extended description of the task with any extra information 

(up to 1000 characters)  (The Today button will 
paste today's date into the text.

When you tap OK the task will appear on screen in the correct 
place given the sorting method in use.

• tap Edit > Update entry if you need to change any 
details or attributes of a task

• tap Edit > Delete to completely remove a task (if in 
error).

Repeating Tasks
Use repeating tasks for events that occur regularly or to a schedule, eg weekly or monthly meetings, to 
save having to re-enter the details each time.

Repeats can optionally be set on tasks by ticking the box in the New and Update entry screens. Set 
the Repeat with:

• Period as Daily, Weekly, Monthly, Annually

• Interval for the frequency of the period

Example, setting a period of 'weekly' and interval of 3, implies the task should be repeated every 3 
weeks after the original Due date.

Repeated tasks are identified in the task list with a * symbol in the R column.

When a task marked as a repeat is completed and struckout, you will be given the option to re-enable 
it with the same details, but for a new Due date based on the specified period and interval.

Default Tasks
If you find you are often entering similar tasks with the 
same information except for the date or priority, then set 
them up as Default entries.

• tap Tools > Setup defaults > Add default. Give it 
a recognisable name, complete the normal task 
details that will never change, and save it.

• tap Tools > Setup defaults > Update default to 
change any default tasks.

• tap Tools > Setup defaults > Delete default to 
remove any default tasks.

To enter a Default Task in a Task Group, tap Edit > Use 
default entry, and select the default by Name. The task 
entry fields will be automatically filled in, so change 
anything if required, and enter. Default tasks are Group 
specific.

Sorting
Use the various sorting methods to view the tasks in your preferred order:

• tap on the column title to sort on the attribute (Date, Priority, Description, Project or Type 
category).
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• tap a second time to reverse the sort order.

• use the Sorted by: selector at the bottom of the screen to choose the sort method.

• tap the blank button above the scrollbar, or use Tools > Turn Sort Off, to turn automatic 
sorting off. Then use Edit > Move entry to manually order the tasks.

Set whether undated tasks are sorted last or first with the option in Tools > Preferences > Display.

Managing Tasks
There are various features of the program that can help to manage your tasks:

• Change the sorting method to best view the tasks by tapping on the appropriate column 
header.

• Filter on the screen to only display the tasks matching your criteria.

• Create unprioritised tasks (implying that they are not important) by setting the priority as 
'None' in the task entry or update screen.

• Create undated tasks (implying they have to be done 'sometime') by unticking the Dated box 
in the task entry or update screen.

• Overdue tasks will be shown in red text, or select your own colour from Tools > Preferences 
> Colors.

Use the quick action buttons at bottom right of screen:

• Use P (or the Edit > Entry in progress menu option) to mark a task that you are working on 
as "in progress", when it will be shown in italics.

• Use T to quickly set a task to today's date.

• Use X to quickly view or update the Extended Text description of a task.

• Use S (or the Edit > Strikeout entry menu option) to mark a task as completed, when it is 
shown in strikeout.

Many of the task attributes (in progress italic, overdue colour) can be turned off, if you don't wish to 
use them, with the 'Use attributes' option in Tools > Preferences > Display.

Filtering
Both the Task Group and Archive screens can be filtered to show only those entries that meet your 
selected criteria.

Tap Tools > Filter and enter any combination of criteria:

• Tick the Filtered checkbox to apply the filter. Untick to 
remove the filter.

• Select one or a combination of filters:
- on a single group or 'All' groups
- on a Project and /or Type category
- Include or Exclude Undated Tasks
- by a Date range
- on a Text string.

A colored 'Filtered' bar at the bottom of the screen indicates that a 
filter is applied and allows quick access to the filter set screen for 
applying another filter, or turning it off.

Note that tasks cannot be updated or modified in the Filtered view.
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Completing Tasks
As you actually complete your tasks, cross them out from the list with Edit > Strikeout entry, or using 
the S button. They will then be shown in strikeout font. A setting in Tools > Preferences > Display 
allows you to select if you want Struckout tasks grouped or not, and if yes whether they will sort in first 
or last position in the Task Group.
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Later you can periodically remove the struckout tasks from 
the active ToDo list or archive them as a permanent record 
of your completed activities. The Edit > Archive entries 
dialog gives the flexibility to: 

• Archive or Remove (delete) the entries,

• act on only the Struckout entries, or All entries,

• select the required Archive File.

Preferences
Tools > Preferences gives access to many options for configuring the display and operation of the 
program:

Settings
• Maximum Priority - set how many levels of priority to use.

• Use Project category and Use Type category - allows you to use both categories, just one, 
or neither of them.

• Whether you wish to use the pop-up keyboard in Landscape mode.

Display
• Whether to display the task Attributes - italic for "in 

progress", red for "overdue". (Note that there may be a 
speed penalty for using these.) This setting is Group 
specific.

• Group Strikeout - whether to group the struckout tasks in 
the list Last, First or not at all. This setting applies to all 
Task Groups.

• Undated Tasks - whether to display these Last or First in 
the list.

Font
Set the screen display for the records (note that some of these are used anyway for task attributes):

• Font type and Size

• Font type and Size

• Color

• Font style - Bold, Italic, Underline, Strikeout

Filter
Set default settings for the filter screen:

• Include/Exclude Undated Tasks

• Start Date and Finish Date

Category names
• Your preferred name for each of the two categories. This 

setting is Group specific.
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Colors
Set your color choice for:

• Screen background

• Column headers

• Screen buttons

• Selected screen button

• Dialog background

• Overdue tasks

Backup
• Specify the location for backup files

• Whether you wish the program to carry out a backup 
automatically

• Where you want to see a confirmation dialog before 
backup runs

• The period and start date for the backups.

In Archive there are additional Preferences related to that specific screen:

Display
• The total task entries in the file are buffered for speed of display on screen. Use this to set 

your optimal value for the number of entries per screen.
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Archive Screen
This screen allows you to view completed tasks previously archived from Task Groups. It is similar to 
the main Tasks screen, except that you cannot edit the entries.

Use Edit > Create archive in the Tasks screen, or tap New in the Archive screen to create new archive 
files and give them a name. You can use one archive to accumulate all task entries, create an archive 
file per year, or create as many files as you wish. Edit menu options also allow them to be Renamed or 
Deleted.

Switch Archive files using the drop down selector at top right of the screen.

The entries in the archive file are buffered for speed of display on screen. The default buffer size is set 
to 13 entries (the number of visible lines on screen), but is configurable with Tools > Preferences > 
Display. To move around the entries on screen:

• tap the S button to jump to the Start of the file (earliest tasks)

• tap the Prev button to display the previous display buffer

• tap the Next button to display the next display buffer

• tap the E button to jump to the End of the file (most recent tasks).

Other Archive Functions
Other functions available in the Archive screen Tools menu are:

Reset start date
To remove earlier unwanted entries if the file gets too big.

Filter
Filter display - allows you to view only the entries belonging to a Category, Date range or with 
particular Description text.

Find
Find entry and Find next functions for text entries.

Jump to entry
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To show the screen with a particular task entry (the entries belonging to each screen buffer are 
numbered in the window at the bottom of the screen).

Jump to date
To show the screen buffer with a particular dated task entry.
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Additional functions
Register Program
Use Tools > Register program to enter your personal registration code to allow full use of the program 
without data restrictions. This function is also available from the opening 'nag' screen.

About
Use Tools > About to obtain contact details for RMR Software and information about the program.

Backup and Restore
The program has Backup and Restore options in the Data menu of most screens:

• Use Backup data to regularly make a second copy of your data files in the "My Documents" folder 
in case of accidental deletion or loss. In that way the data can also be saved to a PC each time 
you hot-sync.

• Use Restore to subsequently reload the backed up files if necessary. The program expects to find 
the data in the /My Documents/RMRBackups/RMRTask/ folder.

Export Entries
Tap Data > Export entries to export details of the whole Task Group or Archive file to a text file in 
either TAB-delimited (ASCII) or Comma-Separated-Variable (CSV) formats for use in a spreadsheet or 
wordprocessor.
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